Back to overview
Resolved

Scheduled Maintenance: Global router upgrade and Nebius image rollouts

Aug 3, 2026 at 7:00am UTC  –  Aug 3, 2026 at 11:00am UTC
Affected services
US
EU

Resolved
Aug 3, 2026 at 11:00am UTC

Maintenance ended

Updated
Aug 3, 2026 at 9:58am UTC

Maintenance is taking longer than anticipated and will continue for an additional hour. As team rolls out updates we do our best to ensure that services are not disrupted.

Thank you for your patience and understanding

Created
Aug 3, 2026 at 7:00am UTC

We are upgrading our global router to improve latency and routing decisions, and rolling out new machine images across our Nebius regions to enable checkpointing.

Requests routed through the global router may see increased latency or transient errors while the upgrade rolls out.

Nodes in Nebius eu-north1 and us-central1 will be rolled onto the new image. Active runs in these regions may be interrupted.

Regions outside Nebius are not affected by the image rollout. Deployments and inference requests may still see elevated latency across all regions while the router work completes.

If you run latency-sensitive production traffic, plan for retries during the window. We will post updates here as the work progresses.