Back to overview
Resolved
Registry unavailable in EU-North1
Jul 26, 2026 at 5:27pm UTC
Affected services
Registry EU
Resolved
Jul 26, 2026 at 5:32pm UTC
Normal operation has resumed.
Affected services
Created
Jul 26, 2026 at 5:27pm UTC
We are receiving and investigating reports of issues with our Registry in the Nebius EU-North1 cluster.
Affected services