Back to overview
Resolved
Planned maintenance in Crusoe provider
Jul 30, 2026 at 8:00am UTC
–
Jul 30, 2026 at 12:00pm UTC
Affected services
US
Resolved
Jul 30, 2026 at 12:00pm UTC
Maintenance ended
Affected services
Created
Jul 30, 2026 at 8:00am UTC
One of our upstream infrastructure providers will be conducting planned network maintenance in the us-southcentral region.
No customer action is required. Workloads will be moved to alternative capacity automatically ahead of the window. You should see no change in availability or performance.
All other regions remain fully operational.
If you notice any issues during or after the window, please reach out to us.
Affected services