New builds & inference in US are currently affected by ongoing maintenance downstream
Resolved
Jul 16, 2026 at 8:37pm UTC
Maintenance has been completed and the region is fully restored. Expect a few slower cold starts while caches warm up.
Affected services
Updated
Jul 16, 2026 at 5:24pm UTC
Maintenance in the us-east1-a region is complete. Our upstream provider is still restoring access to a small number of remaining hypervisors, expected to be fully recovered by 17:45 UTC, at which point (and after verification) access to the region will be restored.
Customers on our global router remain unaffected (Insofar as inference is concerned). Traffic has been failing over to other regions and providers throughout, no action required.
Builds continue to remain affected
If you have workloads pinned directly to us-east1-a that are still unavailable, they should recover automatically. You can also pin to a different provider or region in the meantime.
Affected services
Created
Jul 16, 2026 at 12:38pm UTC
Planned maintenance is affecting new builds in the US from starting. We expect this to be resolved shortly.
Inference and other services are not affected.
Affected services