Back to overview
Resolved
Degraded registry performance in AWS us-east-1
Jun 30, 2026 at 8:00pm UTC
Affected services
Build Service
Registry US
US
Resolved
Jul 1, 2026 at 1:39pm UTC
We've identified the root cause of the issue as constrained registry resources. These resources have been scaled and the issue has been resolved
Affected services
Created
Jun 30, 2026 at 8:00pm UTC
We're currently experiencing degraded registry performance do to an issue with a service related to an upstream provider. We are currently investigating and will provide an update as soon as we have been able to identify the cause.
Affected services