Back to overview
Maintenance

Scheduled Maintenance: Crusoe us-east-1 region unavailable

Jun 16, 2026 at 10:00am UTC  –  Jun 16, 2026 at 4:00pm UTC
Affected services
US EAST 1

Resolved
Jun 16, 2026 at 4:00pm UTC

Maintenance ended

Created
Jun 16, 2026 at 10:00am UTC

We are performing urgent maintenance in our Crusoe us-east-1 region tomorrow, from 10:00 - 16:00 UTC. Apps pinned to this region and provider will be affected for the duration of the window. To avoid interruption, please deploy to another Cerebrium region or provider before 10:00 UTC tomorrow.

Apps running on our new global infrastructure are unaffected. They will fail over automatically to other regions/providers - no action is required.

Thank you for your continued support and patience.