Unable to schedule workloads in crusoe us-east-1a
Resolved
May 20, 2026 at 7:02pm UTC
Upstream provider is back online and all services have been restored.
Affected services
Updated
May 20, 2026 at 9:42am UTC
Crusoe is making progress on mitigation in us-east-1. A number of VMs have returned to service, though a subset of compute hosts is still impacted and the incident isn't fully resolved yet.
Engineering on the upstream side remains actively engaged. We'll continue posting updates as recovery progresses.
Affected services
Updated
May 20, 2026 at 8:27am UTC
Crusoe has a mitigation plan in place and is currently testing it. Early results are positive, with a few more tests to run before applying it across all impacted hosts.
We'll post another update once the mitigation is rolled out or if anything changes. Workloads in Crusoe us-east-1 remain affected in the meantime.
Affected services
Created
May 20, 2026 at 3:30am UTC
We're seeing a full outage of our Crusoe us-east-1 region affecting all workloads deployed there. The upstream provider is experiencing an infrastructure failure and we're working with them on resolution.
Impact: All apps deployed to Crusoe us-east-1 are unavailable. Requests to affected deployments will fail.
Workaround: If your app is configured for multi-region or has a fallback region, traffic should route automatically. Customers running solely in Crusoe us-east-1 can redeploy to another region (e.g. AWS us-east-1, AWS us-east-2) in the meantime.
We'll post updates here as we have them. Apologies for the disruption.
Affected services