Unable to schedule workloads on Crusoe (both regions)
Resolved
May 14, 2026 at 1:01pm UTC
Workloads in both Crusoe regions are running normally again.
After rolling back the change, we manually cleared the broken state in our infrastructure and brought capacity back online. A post-mortem will follow.
Thanks for your patience.
Affected services
Updated
May 14, 2026 at 11:49am UTC
We've identified and mitigated the underlying issue and are now working to bring services back online in both Crusoe regions. Workloads are not yet schedulable while recovery is underway.
Next update in 30 minutes or when resolved.
Affected services
Created
May 14, 2026 at 11:07am UTC
We've identified an issue affecting both new deployments and running workloads in our Crusoe regions. A recent internal release is preventing workloads from running correctly.
We're rolling back the change now and expect things to recover shortly.
Next update in 30 minutes or when resolved.
Affected services