Back to overview
Resolved

Slow container image pulls in eu-north1

Sep 8, 2026 at 3:36pm UTC
Affected services
Registry EU

Resolved
Sep 8, 2026 at 4:42pm UTC

The issue has been resolved.

Created
Sep 8, 2026 at 3:36pm UTC

We're seeing elevated S3 latency in eu-north1, which is slowing container image pulls. New deploys and cold starts in that region are taking longer than usual.

Inference is unaffected: apps with warm replicas are serving traffic, and other regions are running normally.

We're currently investigating and will post an update shortly.