Back to overview
Resolved

Provider network outage: Nebius eu-north1

Sep 2, 2026 at 9:57am UTC
Affected services
EU

Resolved
Sep 2, 2026 at 5:17pm UTC

The issue has been resolved and the provider and region are stable again.

Created
Sep 2, 2026 at 9:57am UTC

We are currently tracking intermittent network outages with an upstream provider (Nebius) in the eu-north1 region. We are working with provider to identify and resolve the issue and will provide updates as the provider investigations progress.